WhatsApp su iPhone 3G funziona di nuovo?

di Nicola Strumia 40

Ci sono stati interessanti sviluppi nelle ultime ore per quanto riguarda  l’impossibilità di far funzionare WhatsApp sugli iPhone 3G. L’incompatibilità era legata al fatto che l’SDK di XCode 4.5 non supporta la retro-compatibilità con i vecchi dispositivi. Al di là di pseudo-appelli e web-rivolte lanciate da alcuni blog del settore ora contro gli sviluppatori di WhatsApp ora contro Apple, diversi utenti, alcuni dei quali hanno anche effettuato utilissime segnalazioni nei commenti al nostro articolo precedente (grazie ragazzi/e!) hanno visto WhatsApp riprendere vita sul proprio iPhone 3G, anche se con successo contrastante.

Personalmente sono uno degli utenti cui la nota applicazione di messaggistica ancora non funziona. In realtà la mia situazione è sicuramente differente da quella di altri. Io, nei vari tentativi effettuati, ho provveduto anche a cancellare l’app dal mio iPhone; quello che succede adesso è che non riesco a scaricare WhatsApp dallo Store. Ricevo continuamente il messaggio in cui viene esplicitato che è necessario avere iOS 4.3.

Probabilmente WhatsApp è tornato a funzionare sui dispositivi in cui l’App non era stata rimossa manualmente dal dispositivo.
Ma ci sono diversi utenti che segnalano che l’App non sia tornata a funzionare nonostante questa non sia mai stata rimossa dal device o altri che segnalano di non aver ricevuto il PIN di ri-attivazione.
Sul blog ufficiale del team di sviluppo di WhatsApp non sono stati (ancora) pubblicati post di update relativi a come sia evoluta la questione, il blog è infatti fermo al post di annuncio dello scorso 29 dicembre.
Quanto alle colpe, ci sono due versioni contrastanti. Secondo alcuni è colpa di Apple, secondo altri, di Whatsapp.
Frakie, nei commenti al nostro post, ci segnala questo intervento trovato nei forum di supporto Apple:

“To be clear. There are two issues here. Support for iOS 4.2 and support for the older version of WhatsApp which will work on the 3G.

iOS 4.2: The developers cannot support this anymore. This is due to xcode 4.5 which will not build armv6 executables – which the 3G needs. That’s the price of progress, nothing the devs can do here.

Older version of WhatsApp (which works on the 3G): stopping support for the old version of the app IS a decision of the developers and has nothing to do with Apple. The old app should still be able to talk across the WhatsApp network using their protocol but they have decided to block access for this old version of the app. Here is where the problem is. To block the 3G version of the app IS a decision of WhatsApp. There may be a valid reason for this, such as insecurity in the protocol WhatsApp uses but they are not saying so. Incorrectly blaming Apple and simply switching access off is a shady move, especially for a paid app.”

In sostanza il problema sarebbe che la vecchia versione dell’applicazione potrebbe funzionare ancora sul network di Whatsapp ma per qualche ragione che Whatsapp non vuole rivelare è stato bloccato l’accesso al network all’app compatibile con iPhone 3G. Non è da escludere che vi siano problemi di sicurezza alla base di questa decisione, che dunque non dipenderebbe più soltanto dall’impossibilità di lavorare all’app con le ultime versioni di XCode.

A questo punto, oltre a continuare a usare la messaggistica di Viber (il numero di utenti tra i miei contatti che attualmente usano eBuddy XMS è davvero troppo ridotto), proverò a fare un ripristino di un back-up tramite iTunes, un back-up in cui ovviamente era presente ed installato WhatsApp.
A seguire, in caso di non funzionamento, seguirà test con il custom firmware di Whited00r v.6.
Avete altre idee in merito?